Home Forums Warehouse Insight the request failed with http status 401 unauthorized

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • Nirmala KarunarathnaNirmala Karunarathna
      Post count: 5

      I am trying to access Warehouse Insight on an Android device. I scanned the configuration barcode (combined barcode). The device prompted me to enter Windows credentials. I entered Business Central credentials. It showed me this error
      the request failed with http status 401 unauthorized

      Please prepare some proper user manuals.

      Which Windows credentials it is asking for?

      Chris ReidChris Reid
        Post count: 6

        When connecting to a Business Central cloud environment, you will want to use OAuth as the login method. You can select that option from the Warehouse Insight Device Configuration report or the Warehouse Insight Installation report. A Windows login method would be used when connecting to an on-premise Business Central instance configured with either the Windows or NavUserPassword credential-types.

        To scan the configuration barcode, from the Windows login screen, you can select the back arrow on your device until you are brought to a blank screen in the Warehouse Insight application and scan the new barcode from there. If you are prompted for a configuration password, the default password is 1234.

        The other method to change the login mode would be to select the menu at the top of the blank screen, select Configure, and input the configuration password. Then you can select the menu and navigate to Logins. From there you can change the method to OAuth and then select the menu to close and save changes.

        Nirmala KarunarathnaNirmala Karunarathna
          Post count: 5

          I selected OData as the service type and OAuth as the login method on the configuration report. still, it is asking to enter Windows credentials.

          Service type – OData
          Login method – OAuth

          Chris ReidChris Reid
            Post count: 6

            When you generated the configuration report, was the “include Login Mode” option still enabled? Did you also try the second option of changing the login mode from the menu in the application? After pressing back to exit the login screen, select the menu at the top of the blank screen, select Configure, and input the configuration password. Then you can select the menu and navigate to Logins. From there you can change the method to OAuth and then select the menu to close and save changes.

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.