Home Forums WMS Express Resource not found for the segment ‘WHI_ExecuteEventJson’

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Michael CoxMichael Cox
      Post count: 8

      I got this error when I tried to install the trial version of Advanced Inventory Count.  I uninstalled WHI trial version and I am still getting this error.  I have deleted the app on both scanners and reinstalled.  I have ran the setup for WHX twice but I still get this error.

      Michael Cox

      Terri Vaive
        Post count: 154

        Hello Michael,

        Warehouse Insight is required for Advanced inventory count. You will need to reinstall it, rerun the setup, and then try again.

        Thank you,

         

        Michael CoxMichael Cox
          Post count: 8

          I would just like to go back to the Express version.

          Michael CoxMichael Cox
            Post count: 8

            Warehouse Insight Advanced is available.  Will that work?  I just need to be able to use my scanners again.

            Matthew DobeckMatthew Dobeck
              Post count: 11

              I’m getting this same error.  I re-ran the WMX Express setup wizard in BC as well as reinstalling the app on the device.  Any ideas on how to get past this error?

              Terri Vaive
                Post count: 154

                Hello Matthew,

                While Warehouse Insight and WMS Express can be installed together they will conflict and cause issues. You should only have one installed in your environment at a time.

                What is most likely occurring is that when you uninstall one extension it is removing the Web Service that both Warehouse Insight and WMS Express rely on so it will need to be recreated.

                To do this, navigate to the “Web Services” page in Business Central and search for the “WHI” entry. If it exists, go ahead and remove it so you can recreate it.

                Now add a new web service with the following:

                1. Object Type: Codeunit
                2. Object ID: 23044900
                3. Service Name: WHI
                4. Published: Yes.

                After creating the new web service, close the page and ensure that it has saved and try connecting the scanner again.

                Thank you,

                Matthew DobeckMatthew Dobeck
                  Post count: 11

                  This corrected the problem.  Thank you so much for the quick help!!

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.