Home Forums Warehouse Insight Log in via App (Error 401 Unauthorized)

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • Afonso CorreiaAfonso Correia
      Post count: 2

      Hi,

      We have installed Insight Works and executed the Assisted Setup for BC22.6 OnPrem, all the steps were executed following the instructions.

      We use:

      Login Method: Windows
      Service Type: SOAP

      We did some trial by copying the SOAP link and paste it on the Android scanner browser, we we able to login.

      We have checked that we were using the full WebServiceKey.

      Does anyone have an idea what might be incorrect?

      Thanks in advance.

      Michael ArmentaMichael Armenta
        Post count: 14

        Hi Afonso,

        Thanks for reaching out! To connect an Android scanner to your current Business Central environment, you will need a copy of the current Business Central on-prem instance created with NavUserPassword credential type that is pointing to the same database. The scanner app users will need to be on this NavUserPassword instance. Users’ setup using Windows authentication (domain\user) will be unable to login on an Android scanner. To connect Android based scanners to Business Central on-prem you will need to create a new BC instance that points to the same database that is configured for NavUserPassword Authentication that the scanners will use to login.

        The Warehouse Insight application itself should be configured as Login method set to Windows and Web Service type set to SOAP. The credentials used will be the NavUserPassword credentials: 5. Signing In – Insight Works Knowledge Base (dmsiworks.com)

        Steps for the configuration follow the Cloud based steps for modern Business Central, with the exception of the steps mentioned above and publishing and installing via admin shell: 4. Configuring the Software – Insight Works Knowledge Base (dmsiworks.com)

        On the Warehouse Insight Application, if you navigate to Menu > Configure > System, you’ll be able to verify on the Web Service field if it is connected to the NavUserPassword instance. Please ensure that both the instance name and port are connecting to the correct instance. The web service URL will be in the following format: [IP/Computer Name]:[Port]/[Instance]/[WS/ReplaceWithAPercentEncodedCompanyName/Codeunit/WHI]

        Note: You do not have to modify the following part of the url: ReplaceWithAPercentEncodedCompanyName

        Best,

        Afonso CorreiaAfonso Correia
          Post count: 2

          Hi Michael,

          Thank you so much for your support.
          It’s working perfectly now, the new BC instance fixed it.

          BR,

          Afonso

        Viewing 3 posts - 1 through 3 (of 3 total)
        • You must be logged in to reply to this topic.