Home Forums Warehouse Insight Installation Error – Request Data is Invalid

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • Lindsay HunterLindsay Hunter
      Post count: 16

      Hi,

      I’ve done a few successful installations of WHI before but for the first time I am getting this error when trying to install it as a test run for a client.

      ‘Request Data is invalid. Ensure all configurations have been completed, including Assisted Setup.

      I have run through the assisted setup up twice (got an installation report for both), my user has been setup as a user in the Insight works user table. As is the location code for devices. I do not have access to a scanner so this is being run on an emulator as a test which means I cannot take a picture of the barcodes to setup.

      What could possibly be causing this?

      Lindsay HunterLindsay Hunter
        Post count: 16

        Additional Informaiton

        This is after I sign in with my business central username and password. And the license I have is a ‘Delegated Partner’. The license might be the issue, but would like to confirm that before purchasing a new one.

        Michael ArmentaMichael Armenta
          Post count: 14

          Hi Lindsay,

          Thank for reaching out. The user signing into the application will require either a Full User License or a Device License.

          What licenses do I require to use apps from Insight Works? – Insight Works Knowledge Base (dmsiworks.com)

          Regards,

          Lindsay HunterLindsay Hunter
            Post count: 16

            Hi Michael,

            That was indeed the issue! Thank you for your help.

            As feedback maybe change the error message to be more detailed as the current one “Request Data is invalid. Ensure all configurations have been completed, including Assisted Setup.” is not at all what was causing the issue.

            Lindsay HunterLindsay Hunter
              Post count: 16

              Actually sorry, we got to the permission screen but then the same error has appeared, so it wasn’t a license issue.

              Lindsay HunterLindsay Hunter
                Post count: 16

                I have moved my testing to a phone and was able to scan the barcodes and it works.

                Might have been something weird with the emulator.

                We’re moving forward with a phone testing now.

                Thank you for the help Michael.

              Viewing 6 posts - 1 through 6 (of 6 total)
              • You must be logged in to reply to this topic.