Home Forums WMS Express Basic Authentication doesn’t seem to work with BC Ver: 18.1.24822.24906

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • Anonymous
    Post count: 2

    Basic Authentication (via the web services access) doesn’t appear to work for me in environments that have recently been upgraded to  Business Central (Saas) version 18.1.24822.24906.

    they are still working in our previous versions.

    I’ve tried this in Postman as well and seem to have a similar issue.

    I read the post on warnings about changes to basic authentication taking place by Oct.  2021 but I didn’t expect it to happen this quickly.

    Is anyone else experiencing this?

    If so, is there another way to authenticate yet?

    Thanks Harry.

     

    Romeo SantosRomeo Santos
    Post count: 3

    Hi Harry,

    Authenticating via the Web Service Access Key should not be depreciated yet. As you said we are expecting it by Fall 2021.

    What error are you getting when trying to login/authenticate?

    We will have a new way to authenticate with the WHI 2.5 update, which is scheduled to release this coming June.

    Regards,

    Anonymous
    Post count: 2

    Thanks so much.

    I don’t get an error on the scanner.  The wheel just spins and it doesn’t appear to make a connection.

    It helps a lot to know it is working for everyone else.  That way I can focus on what ever local issues might be causing it.

     

    Thanks,

    Harry.

    Romeo SantosRomeo Santos
    Post count: 3

    Hi Harry,

    I would first check that you are using the right web service. You will want to use the WHI Data Broker which can be found in the Web Services page in BC.

    If the wheel just continues to spin, it could be a few issues. A weak network connection on the scanner is one possible reason. Another being a slow web service call, in which case the issue is with the BC environment itself.

    Another thing to check would be on the scanner. In WHI, Menu -> Configure (if it prompts for a password, it is 1234) -> Menu -> Data. Make sure Data is disabled and clear the data cache.

    Regards,

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.