Home Forums Warehouse Insight App just swirls for eternity when opened

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Brett FBrett F
      Post count: 18

      I updated the app successfully, but now when we go to open the app, it just has the orange circle swirling forever.  How do I fix this?

       

      Michael ArmentaMichael Armenta
        Post count: 14

        Hi Brett,

        Thanks for reaching out. After the application was updated on the device, was the update on the Business Central side completed as well? If not, I would recommend following the steps in our knowledge base article here: Update Warehouse Insight on Business Central SaaS – Insight Works Knowledge Base (dmsiworks.com)

        Does an error ever occur on the application, if so, could you provide a screenshot of the error you are receiving? If the max OData or SOAP requests have been reached, you may experience issues with connecting Operation Limits in Dynamics 365 Business Central – Business Central | Microsoft Learn

        Does the device have a stable connection to the network? Can you also verify if it is connected to the internet.

        Another thing to try would be copying the web service and pasting it in a browser on the device. This would verify if you’re able to establish a connection to the web service in Business Central.

        Please let me know if you have any further questions!

        Regards,

        Brett FBrett F
          Post count: 18

          Hi,

          The update was done on the BC side first.
          There is no error, it just swirls and I cannot get to the configurations or go anywhere.

          I did verify it is connected to a stable internet connection.

          When I copied and pasted the web service into the browser, I got this error: Authentication Invalid Credentials
          Web service access key is no longer supported as authentication please use OAuth.

          The web service is OAuth so I am not sure why I would get that error.

           

          Thank you.

          Michael ArmentaMichael Armenta
            Post count: 14

            Hi Brett,

            The message you received when singing into the web service on a web browser is normal as you can’t launch the application on the browser. This was mainly to a test to verify you’re able to connect to that web service, which it appears you are able to. We’ll need some more information to look into this further. Which version of the Warehouse Insight application are you using (on both Business Central and the device)? Could you also provide the make/model of the device running Warehouse Insight? We can attempt to uninstall and reinstall the application to the updated version and verify if the issue persists. To do so, you can follow the steps below:

            In Business Central:

            1. Search for Warehouse Insight Installation Report.
            2. Select the desired configuration code.
              1. If your Business Central is SaaS, you can set the Service Type to OData, and the login Method to OAuth.
              2. If your Business Central is on-prem, you can set the Service Type to Soap and the Login Method to Windows.
            3. Toggle off the use of additional insight works users if they are not in use.
            4. Select Print or Preview and Close

            On the Device:

            1. Tap and hold the Warehouse Insight application until you get the option to select Uninstall.
              1. You can also select App Info and then select Uninstall.
            2. Once the application is uninstalled, we’ll need to re-install the newer version and configure the application to your environment.
            3. Navigate to a web browser and select the address bar and scan the Step 1 barcode for Android devices.
            4. Once installed, open the Warehouse Insight application and scan the Step 2 barcode to configure the application to your environment.
            5. Finally, sign in.

            Regards,

            Brett FBrett F
              Post count: 18

              I tried uninstalling and reinstalling and get the same issue but I did realize that I can click back once in the app to get back to the menu that has configurations.  It never allowed me to get to the screen to sign in after I entered the configurations.

              The app version is 2.13.8908.1

              BC version is 2.13.8907.1

              Is this my issue? 08 vs 07?

               

              I do see there is an available update to 2.13.8925.1

               

              Thank you.

              Brett FBrett F
                Post count: 18

                The Device is a Keyence BTA700

                Michael ArmentaMichael Armenta
                  Post count: 14

                  Hi Brett,

                  You can use this one time link to schedule a meeting with me and we can take a closer look.

                  Book a Meeting

                  Regards,

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.